import Foundation
let pattern = #"(?:^|&)(page=)\d+(?=&(?:.*&)?\1)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
page=2&page=3&page=4
page=2&page=3
page=2&foo=bar&page=3
page=2
other_parameter=other_value&page=2&another_paramenter=another_value
other_parameter=other_value&page=2&page=3&page=4&another_paramenter=another_value
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)