use strict;
my $str = 'page=2&page=3&page=4
page=2&page=3
page=2&foo=bar&page=3
page=2
other_parameter=other_value&page=2&another_paramenter=another_value
other_parameter=other_value&page=2&page=3&page=4&another_paramenter=another_value';
my $regex = qr/(?:^|&)(page=)\d+(?=&(?:.*&)?\1)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}