$re = '/(?:^|&)(page=)\d+(?=&(?:.*&)?\1)/m';
$str = 'page=2&page=3&page=4
page=2&page=3
page=2&foo=bar&page=3
page=2
other_parameter=other_value&page=2&another_paramenter=another_value
other_parameter=other_value&page=2&page=3&page=4&another_paramenter=another_value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);