#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<ApWord>((\w+)(')(\w+)))|(?<HyWord>((\w+)(-)(\w+)))|(?<Rest>\w+)"
Local $sString = "something else +good -bad 'other stuff' ++'good stuff' -"bad stuff" ---"dall'orto" a v I_m a and bdc" & @CRLF & _
"let's see if other-stuff works let1234 a123d k n _d .,;'\]=!@#$%^&**(())_++}{[]\":';/.,. But what about Mr. Jones"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")