// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<ApWord>((\w+)(')(\w+)))|(?<HyWord>((\w+)(-)(\w+)))|(?<Rest>\w+)").unwrap();
let string = "something else +good -bad 'other stuff' ++'good stuff' -\"bad stuff\" ---\"dall'orto\" a v I_m a and bdc
let's see if other-stuff works let1234 a123d k n _d .,;'\\]=!@#$%^&**(())_++}{[]\\\":';/.,. But what about Mr. Jones";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}