package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)kernel_size\s*=\s*\(\s*(\d+)\s*,\s*(\d+)\s*\)`)
var str = `Conv2D(filters=8, kernel_size=(2, 2), strides=(1,1), padding='valid',
Conv2D(filters=8, kernel_size=( 10 , 20 ), strides=(1,1), padding='valid',`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}