$re = '/kernel_size\s*=\s*\(\s*(\d+)\s*,\s*(\d+)\s*\)/m';
$str = 'Conv2D(filters=8, kernel_size=(2, 2), strides=(1,1), padding=\'valid\',
Conv2D(filters=8, kernel_size=( 10 , 20 ), strides=(1,1), padding=\'valid\',';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);