import re
regex = re.compile(r"kernel_size\s*=\s*\(\s*(\d+)\s*,\s*(\d+)\s*\)", flags=re.MULTILINE)
test_str = ("Conv2D(filters=8, kernel_size=(2, 2), strides=(1,1), padding='valid',\n"
"Conv2D(filters=8, kernel_size=( 10 , 20 ), strides=(1,1), padding='valid',")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")