use strict;
my $str = 'Conv2D(filters=8, kernel_size=(2, 2), strides=(1,1), padding=\'valid\',
Conv2D(filters=8, kernel_size=( 10 , 20 ), strides=(1,1), padding=\'valid\',';
my $regex = qr/kernel_size\s*=\s*\(\s*(\d+)\s*,\s*(\d+)\s*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}