$re = '/[^\\\\u0900-\\\\u0dff^\\\\u0000-\\\\u00ff]/m';
$str = '⏩ മരണം << രണ്ടാം പാപ്പാനായ >> മകന്റെ കൺമുന്നിൽ ’’';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);