re = /[^\\u0900-\\u0dff^\\u0000-\\u00ff]/m
str = '⏩ മരണം << രണ്ടാം പാപ്പാനായ >> മകന്റെ കൺമുന്നിൽ ’’'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end