using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<tipo>titulo)(?P<eleitor>[0-9]{6,8})(?P<DigitoUF>[0-9]{2})(?P<DigVerif>[0-9]{2})(?P<Estado>[A-Z]{2})(?P<Idade>[0-9]{2})";
string input = @"titulo111111112233SP80
titulo111112233SP80
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}