const regex = /(?P<tipo>titulo)(?P<eleitor>[0-9]{6,8})(?P<DigitoUF>[0-9]{2})(?P<DigVerif>[0-9]{2})(?P<Estado>[A-Z]{2})(?P<Idade>[0-9]{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<tipo>titulo)(?P<eleitor>[0-9]{6,8})(?P<DigitoUF>[0-9]{2})(?P<DigVerif>[0-9]{2})(?P<Estado>[A-Z]{2})(?P<Idade>[0-9]{2})', 'gm')
const str = `titulo111111112233SP80
titulo111112233SP80
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}