// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<tipo>titulo)(?P<eleitor>[0-9]{6,8})(?P<DigitoUF>[0-9]{2})(?P<DigVerif>[0-9]{2})(?P<Estado>[A-Z]{2})(?P<Idade>[0-9]{2})").unwrap();
let string = "titulo111111112233SP80
titulo111112233SP80
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}