use strict;
my $str = 'titulo111111112233SP80
titulo111112233SP80
';
my $regex = qr/(?P<tipo>titulo)(?P<eleitor>[0-9]{6,8})(?P<DigitoUF>[0-9]{2})(?P<DigVerif>[0-9]{2})(?P<Estado>[A-Z]{2})(?P<Idade>[0-9]{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}