using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^View_Export_(US_(?:GoM|Horizontals|Onshore))(?:_(Ultimate))?_(\w+)";
string input = @"View_Export_US_Horizontals_Ultimate_DirectionalSurveys";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}