re = /^View_Export_(US_(?:GoM|Horizontals|Onshore))(?:_(Ultimate))?_(\w+)/m
str = 'View_Export_US_Horizontals_Ultimate_DirectionalSurveys'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end