$re = '/^View_Export_(US_(?:GoM|Horizontals|Onshore))(?:_(Ultimate))?_(\w+)/m';
$str = 'View_Export_US_Horizontals_Ultimate_DirectionalSurveys';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);