#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?:)?//([^/]*\.)?example\.com/?"
Local $sString = "With protocol:" & @CRLF & _
"" & @CRLF & _
"http://example.com" & @CRLF & _
"https://example.com/folder/file.txt" & @CRLF & _
"https://www.example.com/toto" & @CRLF & _
"https://sub-domain.example.com" & @CRLF & _
"https://sub-sub.sub.example.com" & @CRLF & _
"https://www.google.com/?q=example.com" & @CRLF & _
"" & @CRLF & _
"Without protocol:" & @CRLF & _
"//example.com/no-i-do-not-want-it-either" & @CRLF & _
"//valid.com/blablabla" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")