const regex = new RegExp('^(https?:)?//([^/]*\\.)?example\\.com/?', 'gm')
const str = `With protocol:
http://example.com
https://example.com/folder/file.txt
https://www.example.com/toto
https://sub-domain.example.com
https://sub-sub.sub.example.com
https://www.google.com/?q=example.com
Without protocol:
//example.com/no-i-do-not-want-it-either
//valid.com/blablabla
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}