package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?://\S+)|([^\s@]+@[^\s@]+)|(\+\d+)`)
var str = `http://google.com
tester@gmail.com
+1818254545400`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}