const regex = new RegExp('(https?://\\S+)|([^\\s@]+@[^\\s@]+)|(\\+\\d+)', 'gm')
const str = `http://google.com
tester@gmail.com
+1818254545400`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}