re = /(https?:\/\/\S+)|([^\s@]+@[^\s@]+)|(\+\d+)/m
str = 'http://google.com
tester@gmail.com
+1818254545400'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end