$re = '~(https?://\S+)|([^\s@]+@[^\s@]+)|(\+\d+)~m';
$str = 'http://google.com
tester@gmail.com
+1818254545400';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);