#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(.+?)>[^<]+<\/\1>"
Local $sString = "<EightSquaredSchema xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xdt="http://www.w3.org/2005/xpath-datatypes" xmlns:fn="http://www.w3.org/2005/xpath-functions">" & @CRLF & _
" <A>" & @CRLF & _
" <nested-A>valid text</nested-A>" & @CRLF & _
" Remove text not inside valid xml braces" & @CRLF & _
" <nested-B>more valid text here</nested-B>" & @CRLF & _
"</A>" & @CRLF & _
"</EightSquaredSchema>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")