import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(.+?)>[^<]+<\\/\\1>";
final String string = "<EightSquaredSchema xmlns:xs=\"http://www.w3.org/2001/XMLSchema\" xmlns:xdt=\"http://www.w3.org/2005/xpath-datatypes\" xmlns:fn=\"http://www.w3.org/2005/xpath-functions\">\n"
+ " <A>\n"
+ " <nested-A>valid text</nested-A>\n"
+ " Remove text not inside valid xml braces\n"
+ " <nested-B>more valid text here</nested-B>\n"
+ "</A>\n"
+ "</EightSquaredSchema>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}