re = /<(.+?)>[^<]+<\/\1>/m
str = '<EightSquaredSchema xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:xdt="http://www.w3.org/2005/xpath-datatypes" xmlns:fn="http://www.w3.org/2005/xpath-functions">
<A>
<nested-A>valid text</nested-A>
Remove text not inside valid xml braces
<nested-B>more valid text here</nested-B>
</A>
</EightSquaredSchema>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end