using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.+?)>[^<]+<\/\1>";
string input = @"<EightSquaredSchema xmlns:xs=""http://www.w3.org/2001/XMLSchema"" xmlns:xdt=""http://www.w3.org/2005/xpath-datatypes"" xmlns:fn=""http://www.w3.org/2005/xpath-functions"">
<A>
<nested-A>valid text</nested-A>
Remove text not inside valid xml braces
<nested-B>more valid text here</nested-B>
</A>
</EightSquaredSchema>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}