using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href\=\\\""(?<url>[^ ]*)";
string input = @"search_name=x, search_now=3.000, info_min_time=1692741600.000, info_max_time=1692828000.000, info_search_time=1692847620.636, app=Digital,
text=""<a href=\""https://support.vodafone.co.uk/1627646512 \"" target=\""_blank\""> ...etc "", info_log=l";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}