const regex = /href\=\\\"(?<url>[^ ]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href\\=\\\\\\"(?<url>[^ ]*)', 'gm')
const str = `search_name=x, search_now=3.000, info_min_time=1692741600.000, info_max_time=1692828000.000, info_search_time=1692847620.636, app=Digital,
text="<a href=\\"https://support.vodafone.co.uk/1627646512 \\" target=\\"_blank\\"> ...etc ", info_log=l`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}