package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{6}(?:,\s\d{6})*$`)
var str = `123456
123456, 456789, 987654
,
1
123456
123456,
,123456
123456,123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}