// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{6}(?:,\s\d{6})*$").unwrap();
let string = "123456
123456, 456789, 987654
,
1
123456
123456,
,123456
123456,123456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}