$re = '/^\d{6}(?:,\s\d{6})*$/m';
$str = '123456
123456, 456789, 987654
,
1
123456
123456,
,123456
123456,123456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);