using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\r|\n){2,}((\s*\/\*\s*\W*\w.+\s*\*\/\s*)|(\s*\/\/\s*\W*\w.+\s*))(\r|\n){2,}";
string input = @"
/*
* comments
*/
code
// comments
code
///////// &777772131@ 7877782388238274
code
/*
comments
*/
code
/*
* /// 34355 $#%#comments
*/
code
// * comments
code
//// comments
code
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}