// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\r|\n){2,}((\s*\/\*\s*\W*\w.+\s*\*\/\s*)|(\s*\/\/\s*\W*\w.+\s*))(\r|\n){2,}").unwrap();
let string = "
/*
* comments
*/
code
// comments
code
///////// &777772131@ 7877782388238274
code
/*
comments
*/
code
/*
* /// 34355 $#%#comments
*/
code
// * comments
code
//// comments
code
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}