# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\r|\n){2,}((\s*\/\*\s*\W*\w.+\s*\*\/\s*)|(\s*\/\/\s*\W*\w.+\s*))(\r|\n){2,}"
test_str = ("\n\n"
"/*\n"
"* comments\n"
"*/\n\n"
"code\n\n"
"// comments\n\n"
"code\n\n"
"///////// &777772131@ 7877782388238274\n\n"
"code\n\n\n\n"
"/*\n"
"comments\n"
"*/ \n\n"
"code\n\n\n\n\n"
" /*\n"
" * /// 34355 $#%#comments\n"
"*/\n\n\n\n"
"code\n\n\n"
"// * comments \n\n\n\n\n\n\n"
"code\n\n\n"
"//// comments\n\n\n\n\n\n\n\n"
"code\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.