import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\r|\\n){2,}((\\s*\\/\\*\\s*\\W*\\w.+\\s*\\*\\/\\s*)|(\\s*\\/\\/\\s*\\W*\\w.+\\s*))(\\r|\\n){2,}";
final String string = "\n\n"
+ "/*\n"
+ "* comments\n"
+ "*/\n\n"
+ "code\n\n"
+ "// comments\n\n"
+ "code\n\n"
+ "///////// &777772131@ 7877782388238274\n\n"
+ "code\n\n\n\n"
+ "/*\n"
+ "comments\n"
+ "*/ \n\n"
+ "code\n\n\n\n\n"
+ " /*\n"
+ " * /// 34355 $#%#comments\n"
+ "*/\n\n\n\n"
+ "code\n\n\n"
+ "// * comments \n\n\n\n\n\n\n"
+ "code\n\n\n"
+ "//// comments\n\n\n\n\n\n\n\n"
+ "code\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}