import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\(\\n]+(?!\\S)";
final String string = "Innere Stadt (Wien)\n"
+ "Leopoldstadt\n"
+ "Landstraße (Wien)\n"
+ "Wieden (Wien)\n"
+ "Margareten\n"
+ "Mariahilf\n"
+ "Neubau (Wien)\n"
+ "Josefstadt (Wien)\n"
+ "Alsergrund\n"
+ "Favoriten\n"
+ "Simmering\n"
+ "Meidling\n"
+ "Hietzing\n"
+ "Penzing (Wien)\n"
+ "Rudolfsheim-Fünfhaus\n"
+ "Ottakring\n"
+ "Hernals\n"
+ "Währing\n"
+ "Döbling\n"
+ "Brigittenau\n"
+ "Floridsdorf\n"
+ "Donaustadt\n"
+ "Liesing (Wien)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}