# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\(\n]+(?!\S)"
test_str = ("Innere Stadt (Wien)\n"
"Leopoldstadt\n"
"Landstraße (Wien)\n"
"Wieden (Wien)\n"
"Margareten\n"
"Mariahilf\n"
"Neubau (Wien)\n"
"Josefstadt (Wien)\n"
"Alsergrund\n"
"Favoriten\n"
"Simmering\n"
"Meidling\n"
"Hietzing\n"
"Penzing (Wien)\n"
"Rudolfsheim-Fünfhaus\n"
"Ottakring\n"
"Hernals\n"
"Währing\n"
"Döbling\n"
"Brigittenau\n"
"Floridsdorf\n"
"Donaustadt\n"
"Liesing (Wien)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.