use strict;
my $str = 'Innere Stadt (Wien)
Leopoldstadt
Landstraße (Wien)
Wieden (Wien)
Margareten
Mariahilf
Neubau (Wien)
Josefstadt (Wien)
Alsergrund
Favoriten
Simmering
Meidling
Hietzing
Penzing (Wien)
Rudolfsheim-Fünfhaus
Ottakring
Hernals
Währing
Döbling
Brigittenau
Floridsdorf
Donaustadt
Liesing (Wien)';
my $regex = qr/^[^\(\n]+(?!\S)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}