$re = '/^[^\(\n]+(?!\S)/m';
$str = 'Innere Stadt (Wien)
Leopoldstadt
Landstraße (Wien)
Wieden (Wien)
Margareten
Mariahilf
Neubau (Wien)
Josefstadt (Wien)
Alsergrund
Favoriten
Simmering
Meidling
Hietzing
Penzing (Wien)
Rudolfsheim-Fünfhaus
Ottakring
Hernals
Währing
Döbling
Brigittenau
Floridsdorf
Donaustadt
Liesing (Wien)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);