const regex = /^.*(?=\/test\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(?=\\\/test\\s)', 'gm')
const str = `/docs/reports/test reports/document1.docx`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);