use strict;
my $str = '/docs/reports/test reports/document1.docx';
my $regex = qr/^.*(?=\/test\s)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";