package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?<amount>.*?)\s*\b(?<unit>tsp|teaspoon|packet|ounces|fl\.\s*ounces|fl\.\s*ounce|cup)\b\s*(?<content>.*)$`)
var str = `2 fl. ounces paprika
3/4 fl.ounce paprika
1 Chopped Tomato
1/2 Cup yogurt
unclear amount of whatever
1 packet pasta
½ tsp fine sea salt
3 sliced onions
1/2 teaspoon heavy cream
2 ounces paprika
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}