import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<amount>.*?)\\s*\\b(?<unit>tsp|teaspoon|packet|ounces|fl\\.\\s*ounces|fl\\.\\s*ounce|cup)\\b\\s*(?<content>.*)$";
final String string = "2 fl. ounces paprika\n"
+ "3/4 fl.ounce paprika\n"
+ "1 Chopped Tomato\n"
+ "1/2 Cup yogurt\n"
+ "unclear amount of whatever\n"
+ "1 packet pasta\n"
+ "½ tsp fine sea salt\n"
+ "3 sliced onions\n"
+ "1/2 teaspoon heavy cream\n"
+ "2 ounces paprika\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}