import re
regex = re.compile(r"^(?<amount>.*?)\s*\b(?<unit>tsp|teaspoon|packet|ounces|fl\.\s*ounces|fl\.\s*ounce|cup)\b\s*(?<content>.*)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("2 fl. ounces paprika\n"
"3/4 fl.ounce paprika\n"
"1 Chopped Tomato\n"
"1/2 Cup yogurt\n"
"unclear amount of whatever\n"
"1 packet pasta\n"
"½ tsp fine sea salt\n"
"3 sliced onions\n"
"1/2 teaspoon heavy cream\n"
"2 ounces paprika\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")