package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/dossier\/test-([0-9]+)-([-a-z0-9]+)\.html$`)
var str = `/dossier/test-42-foobar.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}