const regex = /^\/dossier\/test-([0-9]+)-([-a-z0-9]+)\.html$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/dossier\\\/test-([0-9]+)-([-a-z0-9]+)\\.html$', 'gm')
const str = `/dossier/test-42-foobar.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}