$re = '/^\/dossier\/test-([0-9]+)-([-a-z0-9]+)\.html$/m';
$str = '/dossier/test-42-foobar.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);