re = /^\/dossier\/test-([0-9]+)-([-a-z0-9]+)\.html$/m
str = '/dossier/test-42-foobar.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end